[478380] [Middleton Cross Plains School District] [Middleton] [Power Maintenance]
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 16, 2019 - 14:50 CDT
Investigating
Notification of a planned event affecting your organization:

They are performing a power maintenance at the site today from 8:00 AM CST to 4:00 PM CST.


Please contact the WiscNet NOC if you have any further questions.


608-442-6761 option 1

noc@wiscnet.net
Posted 3 months ago. Mar 28, 2019 - 09:17 CDT
This incident affected: Middleton-Cross Plains Area School District.