[479372] [Plymouth Joint SD] [slow connection]
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 16, 2019 - 14:47 CDT
Investigating
Notification of an unplanned event affecting your institution:

Please be advised we are investigating the the slow speed issue that was reported. We have opened a ticket with the carrier who will continue to investigate this issue.

Please contact the WiscNet NOC if you have any further questions.

608-442-6761 option 1
Posted 3 months ago. Apr 05, 2019 - 11:01 CDT
This incident affected: Plymouth Joint School District.