[351331] [Genoa City J2 School District] [South East] [Site Down]
Incident Report for WiscNet
Resolved
Incident is now resolved.
Posted Mar 21, 2017 - 08:07 CDT
Investigating
Notification of an unplanned event effecting your institution:

Site internet down.

Please contact the WiscNet NOC if you have any further questions.
608-442-6761 option 1
noc@wiscnet.net
Posted Mar 19, 2017 - 05:02 CDT
This incident affected: Genoa City J2 School District.