442613
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted Jul 05, 2018 - 08:49 CDT
Investigating
We are currently seeing devices at this site as unreachable. Please verify power and equipment.
Posted Jul 04, 2018 - 19:52 CDT
This incident affected: Gillett School District.