WiscNet Unable to Receive Support Emails
Incident Report for WiscNet
Resolved
We have continued to receive email support requests for the last several days. The issue appears to be resolved.
Posted Jan 12, 2021 - 14:07 CST
Monitoring
This issue was caused by a failure to forward new email into our ticketing system. We believe we have fixed the problem and will continue to monitor new messages as they come in.

The good news is that we have all the email that was sent to support@wiscnet.net during the outage. Tomorrow, our support team will review those messages and get back to everyone as quickly as we can.
Posted Jan 07, 2021 - 18:10 CST
Investigating
WiscNet has learned that email messages sent to support@wiscnet.net are being rejected. We have engaged our vendors and are investigating the issue.
Posted Jan 07, 2021 - 17:00 CST