497821 | Ithaca School District | Network Down
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 29, 2019 - 14:27 CDT
Investigating
We have opened a ticket to investigate this issue. Power and equipment have been verified on-site and we have engaged the carrier for investigation.

Please contact the WiscNet NOC if you have any further questions.

608-442-6761 option 1
noc@wiscnet.net
Posted 21 days ago. Aug 29, 2019 - 13:07 CDT
This incident affected: Ithaca School District.