WiscNet | Turtle Lake School District Hard Down | TT# 524257
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 08:44 CDT
Investigating
The WiscNet NOC is currently seeing multiple devices as unreachable on site. Please verify power and equipment on site as soon as possible.

Please contact the WiscNet NOC if you have any further questions.


608-442-6761 option 1

noc@wiscnet.net
Posted May 18, 2020 - 12:39 CDT
This incident affected: Turtle Lake School District.