Date & Time: Began at 12:24AM CST 2/24 ended at 3:32AM CST
Time: 105 Minutes
Technicians: Tim B.
This outage was caused by an un-notified maintenance.
Posted Feb 24, 2026 - 08:08 CST
Resolved
Good morning,
Upon further investigation, this outage was caused due to an un-notified maintenance being performed by our local carrier. We have seen services stable since 3:32AM CST this morning.
Posted Feb 24, 2026 - 08:00 CST
Update
We are seeing these devices down again at this time and are reengaging TEACH.
Posted Feb 24, 2026 - 03:06 CST
Investigating
Hello,
Starting at 12:14 am we observed a loss of connection to multiple edge devices.
At this time we are investigating this issue.
Please reach out with any questions.
Thank you,
Posted Feb 24, 2026 - 00:41 CST
This incident affected: TEACH - Madison (Adams-Friendship Area School District, CESA 5, Dodgeville School District, Ithaca School District, Lodi School District, Portage Community School District, Westfield School District).