ShellLake School District Down - 2239437

Incident Report for WiscNet

Postmortem

Power outage caused the circuit to go down. Power came back and the site services restored.

Posted May 20, 2026 - 21:46 CDT

Resolved

Hello,

We saw the power outage clear and the site restore. Please check the equipment at the site and let us know if you have any questions.

Thanks,
Posted May 20, 2026 - 21:45 CDT

Investigating

Hello,

At 7:14 pm CST we saw this circuit go down. We are seeing power outages in the area. Can you confirm power at the site?

Thanks,
Posted May 20, 2026 - 19:35 CDT
This incident affected: TEACH - Madison (Shell Lake School District).