Ithaca School District Down | Ticket 2185088

Incident Report for WiscNet

Resolved

This incident is being resolved as a major incident has been opened on this issue
Posted Dec 17, 2025 - 08:10 CST

Investigating

We are currently investigating this issue.
Posted Dec 17, 2025 - 06:37 CST
This incident affected: TEACH - Madison (Ithaca School District).