We continue to engage the provider and have escalated this issue. we will continue to follow up and will share updates as we receive additional information.
Posted Jul 03, 2025 - 07:28 CDT
Identified
There is a fiber cut between Cambria and Princeton WI. No ETR at this time on repair
Posted Jul 02, 2025 - 13:57 CDT
Update
We have reached out to the provider, who confirmed they are aware of an outage in the region, and are engaging the local carrier for further investigation.
Posted Jul 02, 2025 - 09:01 CDT
Investigating
We are seeing multiple member sites in northeastern Wisconsin have gone down due to a suspected carrier outage. We are engaging the provider, and will share updates as we receive additional information.
Posted Jul 02, 2025 - 08:44 CDT
This incident affects: Beecher-Dunbar-Pembine School District, Coleman School District, Crivitz School District, Goodman-Armstrong Creek School District, Laona School District, Lena School District, Oconto Unified School District, Peshtigo School District, Shiocton School District, and Wausaukee School District.