WiscNet - Multiple customers - DOWN | #2242384

Incident Report for WiscNet

Postmortem

This was due to a widespread power event

Posted May 29, 2026 - 21:40 CDT

Resolved

Hello,


As of 8:30PM we started seeing all services restored. At this point in time this outage has been correlated to a power event.


Thank you,
Posted May 29, 2026 - 21:39 CDT

Investigating

Hello,


Around 7:13PM we started seeing a number of locations down, if you're seeing your service as down please reach out to GLS at 866-558-1920.


Thank you,
Posted May 29, 2026 - 19:29 CDT
This incident affected: TEACH - Madison (Flambeau School District, Frederic School District, Plum City School District, Prescott School District, Saint Croix Central School District, Shell Lake School District, Webster School District).