All affected sites have restored as of 2:12 AM. GLS is currently pending an RFO from their provider. We are currently monitoring the situation, if you have any questions please reach out to Wiscnet or GLS.
Posted Apr 23, 2026 - 02:43 CDT
Update
GLS has escalated this outage with their engineers. Their engineers are hands on with this outage and are working with their vendor at this time. We will provide further updates as we receive them.
Posted Apr 23, 2026 - 01:38 CDT
Update
We have opened ticket 12082754 with GLS. GLS is currently assessing this issue and should provide us an update within the next hour. We will provide further information as we receive it.
Posted Apr 23, 2026 - 00:36 CDT
Investigating
Hello,
Around 11:35PM we started noticing alerts indicating a mass outage. We're investigating now.
Posted Apr 22, 2026 - 23:48 CDT
This incident affected: TEACH - Madison (Cambridge School District, Deerfield Community School District, Kewaskum School District, Parkview School District, Walworth J1 School District) and TEACH - Milwaukee (Kiel Area School District).