#2248350 - Kenosha County - DOWN

Incident Report for WiscNet

Update

Hello,

The WiscNet NOC continues to observe alarms for Kenosha County. We are aware there are power outages in the area, please contact us at 608-442-6761 if you are aware of power issues or have any questions.
Posted Jun 12, 2026 - 11:46 CDT

Investigating

Hello,


We're seeing the connections for the Kenosha County as hard down. If this is expected or there's a known network event please reach out to 608-442-6761.

Thank you,
Posted Jun 11, 2026 - 18:56 CDT
This incident affects: Kenosha County.