2244793 | Edgerton School District 1812 | Down

Incident Report for WiscNet

Resolved

Apologizes for the confusion, as this status page got accidentally updated and close.
Posted Jun 05, 2026 - 21:50 CDT

Monitoring

Apologizes for the confusion, as this status page got accidentally updated and close.
Posted Jun 05, 2026 - 21:44 CDT

Investigating

The WiscNet NOC has lost access to our device for Edgerton School District at 8:52PM CDT 6/5/2026. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact Charter Business for 24x7/outages/incidents at 888-812-2591.
Posted Jun 05, 2026 - 21:27 CDT
This incident affected: Edgerton School District.