Multiple sites down

Incident Report for WiscNet

Resolved

Hello,

At this time we are seeing all alarms cleared and services restored.

Please reach out with any questions.

Thank you,
Posted Sep 24, 2026 - 07:14 CDT

Investigating

Hello,

Starting at 12:14 am we observed these sites go down. At this time we are requesting on site power and equipment verification.

If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920, and use your site ID's listed below.

Walworth J1 School District : 1984
Kiel Area School District : 772
Kewaskum School District : 3184
Parkview School District : 1268
Sauk Prairie School District : 1474

Please reach out with any questions.

Thank you,
Posted Sep 24, 2026 - 00:40 CDT
This incident affected: TEACH - Milwaukee (Kiel Area School District) and TEACH - Madison (Kewaskum School District, Parkview School District, Sauk Prairie School District, Walworth J1 School District).