Medford School District Down | 2212740

Incident Report for WiscNet

Postmortem

This was caused due to a local power outage. We waited for restoral and saw the site restore at 5:25PM.

Posted Mar 11, 2026 - 17:54 CDT

Resolved

We are seeing this device back up as of 5:25PM. This was confirmed to be a power outage local to the area.
Posted Mar 11, 2026 - 17:52 CDT

Investigating

The WiscNet NOC has lost access to our device for Medford School District at 3:18 PM CST. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920.

If you have any additional questions, please contact WiscNet NOC.
Posted Mar 11, 2026 - 15:34 CDT
This incident affected: TEACH - Milwaukee (Medford Area Public School District).