Bowler SD - Down 2247724

Incident Report for WiscNet

Resolved

We are seeing this circuit back up.
Posted Jun 10, 2026 - 19:27 CDT

Investigating

We saw the router at Bowler SD go down at 6:37 pm cst. We have observed power outages in the Shawano area. We will continue to monitor the outage.
Posted Jun 10, 2026 - 19:12 CDT
This incident affected: TEACH - Milwaukee (Bowler School District).