Port Washington-Saukville School District - Down - 12/1

Incident Report for WiscNet

Postmortem

Services restored as of about 11 AM on 12/1.

Posted Dec 02, 2025 - 10:26 CST

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 10:25 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 01, 2025 - 10:37 CST

Investigating

Hello,

Beginning at 9:13 AM on 12/1/2025, alarms were observed indicating an outage affecting Port Washington School District.

While we investigate, we would appreciate any notice of known power or equipment issues on site.
Posted Dec 01, 2025 - 09:36 CST
This incident affected: TEACH - Milwaukee (Port Washington-Saukville School District).