Randall J1 School District | 2210144

Incident Report for WiscNet

Resolved

This event has been resolved, if you have any questions about the outage, please reach out to GLS/TEACH and ask for more information on ticket 11996201.
Posted Mar 05, 2026 - 09:20 CST

Monitoring

We have opened ticket 11996201 with GLS/TEACH. Circuit has restored at 2:09 AM. We will monitor the situation and see if TEACH is aware of anything that may have taken this site down.
Posted Mar 05, 2026 - 02:25 CST

Investigating

We are currently investigating this issue.
Posted Mar 05, 2026 - 02:00 CST
This incident affected: TEACH - Milwaukee (Randall J1 School District).