2238523 | Multiple sites down

Incident Report for WiscNet

Resolved

Hello,

At this time we are seeing all alarms cleared and services restored.

Please reach out with any questions.

Thank you,
Posted May 19, 2026 - 07:26 CDT

Investigating

Hello,

Starting at 12:15 am we observed a loss of connection to our hand of devices for your circuits.

At this time we are requesting onsite power and equipment verification.

Due to a policy change within GLS we are unable to open a ticket with out your consent. They can be contacted at 1.866.558.1920. You can open a ticket with them, below are the site ID's. Please reach out with any questions.

Frederic School District: 517
Saint Croix Central School District: 609
Webster School District: 1806
Wrightstown Community School District: 1897

Thank you,
Posted May 19, 2026 - 00:34 CDT
This incident affected: TEACH - Madison (Frederic School District, Saint Croix Central School District, Webster School District) and TEACH - Milwaukee (Wrightstown Community School District).