Outage | Genoa City J2 School District flapping | 2238074

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 5/18/26 1:02AM

Duration: Multiple bounces, first down at 1:02AM CDT up since 5:29AM CDT.

Technician(s): Octavia G, Tim B

Review Date: 5/18/26

Brief Summary: Power issues at the site caused the device to loose power several times throughout the early morning.

Posted May 18, 2026 - 10:17 CDT

Resolved

We have now seen services up and stable for the past several hours. Upon further review, the router on-site lost power multiple times last night, causing the outage.
Posted May 18, 2026 - 10:15 CDT

Investigating

We are currently looking into this issue. While we investigate are you able to verify if there are any power or cable connectivity issues? Thank you
Posted May 18, 2026 - 04:30 CDT
This incident affected: TEACH - Milwaukee (Genoa City J2 School District).