2244793 | Edgerton School District 1812 | Down

Incident Report for WiscNet

Resolved

Hello,

We observe restored as of 10PM on 6/5.

Feel free to reach out if any further assistance is needed.
Posted Jun 06, 2026 - 13:15 CDT

Identified

Apologizes for the confusion, as the previous status page made for this event got accidentally updated and closed with the wrong information.

James with Edgerton School District has informed WiscNet of the identified fiber and power outage currently impacting the site.

For any questions or concerns, please reach out to the WiscNet NOC.
Posted Jun 05, 2026 - 22:49 CDT
This incident affected: Edgerton School District.