Multiple sites down

Incident Report for WiscNet

Resolved

Hello,

At this time we are seeing all alarms cleared and services restored.

Please reach out with any questions.

Thank you,
Posted Aug 24, 2026 - 04:45 CDT

Investigating

Hello,

Starting at 12:08 am we observed a loss of connection to your sites.

At this time we are requesting onsite power and equipment verification.

Teach is the provider on these circuits, to get a ticket opened with them please contact them at 866-558-1920 and use your site ID's that are listed below:

Mishicot School District: 1132
Two Rivers Public School District: 1674

Please reach out with any questions.

Thank you,
Posted Aug 24, 2026 - 00:21 CDT
This incident affected: TEACH - Milwaukee (Mishicot School District) and TEACH - Madison (Two Rivers Public School District).