Multiple Sites Down | 2254154

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 07:32 CDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 03:43 CDT

Investigating

Hello,

We have observed multiple sites come into alarm indicating an outage affecting the following services.

Brillion School District - TEACH ID: 206
Chilton School District - TEACH ID: 265
Mishicot School District - TEACH ID: 1132
Spring Valley School District - TEACH ID: 1569
Two Rivers School District - TEACH ID: 1674
Reedsville School District - TEACH ID: 1410

At this time we request you verify power and equipment on site and if you require further assistance reach out to TEACH/GLS to open an investigation at 866.558.1920 using the provided TEACH ID.

Thank you,
Posted Jun 30, 2026 - 01:24 CDT
This incident affected: TEACH - Milwaukee (Chilton School District, Mishicot School District, Reedsville School District, Spring Valley School District) and TEACH - Madison (Brillion School District, Two Rivers Public School District).