[2244793] Edgerton School District 1812 | Down

Incident Report for WiscNet

Postmortem

This service restored once the commercial power restored.

Posted Jun 05, 2026 - 20:15 CDT

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 20:15 CDT

Update

Hello,

Upon making contact with Charter, we have been informed that this outage is due to an area power outage.
Posted Jun 05, 2026 - 15:34 CDT

Update

Hello,

We are seeing storms in the area and suspect there could be a local power event occurring.
Posted Jun 05, 2026 - 11:54 CDT

Identified

Hello,

Beginning at 11:41 AM on 6/5/2026, WiscNet has observed the Edgerton School District down.
Posted Jun 05, 2026 - 11:52 CDT
This incident affected: Edgerton School District.