Splicing has been completed and we have seen services restore. Please reach out to us if you have any questions.
Thanks,
Posted Apr 22, 2026 - 17:51 CDT
Update
Hello,
The LMP reports that fiber splicing has begun. ETR is 5:30PM CT. Additional updates will be provided as they become available.
Thanks
Posted Apr 22, 2026 - 16:39 CDT
Update
Hello, The provider has isolated the fiber damage and is starting to prepare the wire for splicing.
Posted Apr 22, 2026 - 15:04 CDT
Identified
Hello,
Our last mile provider isolated a fiber cut in the area. The estimated time of repair is 7 hours.
Posted Apr 22, 2026 - 14:00 CDT
Update
Hello,
We contacted the provider and it was determined that this is part of a larger network event they are experiencing. The issue is still under investigation as to the root cause. We will update you as we learn more.
Thank you,
Posted Apr 22, 2026 - 12:57 CDT
Investigating
Hello,
We are seeing the site down currently. Are you aware of any power issues or maintenance at the site? We will be reaching to the provider and opening a ticket in the meantime.
Thank you,
Posted Apr 22, 2026 - 12:24 CDT
This incident affected: Wisconsin Dells School District.