#2266852 - Stoughton Area School District - DOWN

Incident Report for WiscNet

Postmortem

Spectrum had a fiber outage that was repaired

Posted Jul 25, 2026 - 19:59 CDT

Resolved

Hello,


This outage has been resolved, there was a fiber outage that was repaired.
Posted Jul 25, 2026 - 19:59 CDT

Investigating

Hello,


We're seeing the router associated with the Stoughton Area School District as down. If this is a known event or once power has been confirmed please reach out to 608-442-6761 opt 1.

Thank you,
Posted Jul 25, 2026 - 16:19 CDT
This incident affected: TEACH - Milwaukee (Stoughton Area School District).