TEACH - Madison - Cambridge School District

Incident Report for WiscNet

Resolved

This is part of a larger outage and has been moved to ticket 2185099 for tracking
Posted Dec 17, 2025 - 09:45 CST

Investigating

We apologize. Previous ticket was erroneously closed. This is an isolated incident that is still being investigated
Posted Dec 17, 2025 - 08:09 CST
This incident affected: TEACH - Madison (Cambridge School District).