Date & Time of Incident: 8/3/2026 7:55PM CT
Duration: 21 Min
Technician(s): Brett Schofield, Johnathon Laun
Review Date:
Brief Summary: We observed the handoff port on the device at the school go down
Root Cause: We believe this to be due to maintenance occurring at the school as only the handoff port went down.
Posted Aug 04, 2026 - 08:14 CDT
Resolved
The WiscNet NMC observed the member handoff port for Menominee Indian School District clear at 8:16:25 PM on 8/3/26.
Posted Aug 04, 2026 - 08:10 CDT
Identified
The WiscNet NMC observes the mermber handoff port for Menominee Indian School District at 8/3/2026 7:55:13 PM. Please verify power to your site and the network equipment, and check the cabling for any issues. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920. The TEACH ID for this circuit is **759.**
If you have any additional questions, please contact WiscNet NOC.
Posted Aug 03, 2026 - 20:09 CDT
This incident affected: TEACH - Milwaukee (Menominee Indian School District).