Waterloo School District Down | Ticket 2185097

Incident Report for WiscNet

Resolved

Resolving this ticket as we have opened a major incident
Posted Dec 17, 2025 - 08:07 CST

Investigating

We are currently investigating this issue.
Posted Dec 17, 2025 - 07:29 CST
This incident affected: TEACH - Madison (Waterloo School District).