Edgerton School District - DOWN | #2196536

Incident Report for WiscNet

Resolved

Hello,


We're seeing power restore, and our service has also restored.
Posted Jan 26, 2026 - 20:59 CST

Investigating

Hello,


We are investigating the router for the Edgerton School District being down.
Posted Jan 26, 2026 - 19:49 CST
This incident affected: Edgerton School District.