Cambridge School District - Down | 2233267

Incident Report for WiscNet

Update

We are continuing to investigate this issue.
Posted May 04, 2026 - 15:10 CDT

Update

Hello,

We are seeing the site has restored as of 2:57 PM CST.
Posted May 04, 2026 - 15:10 CDT

Investigating

The WiscNet NOC has lost access to our device for Cambridge School District at 2:22 PM on 5/4/2026. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920. The TEACH ID for this circuit is 238.
Posted May 04, 2026 - 14:59 CDT
This incident affects: TEACH - Madison (Cambridge School District).