BrownCo-GBP - Down

Incident Report for WiscNet

Resolved

Decommissioned circuit
Posted Dec 16, 2025 - 14:36 CST

Investigating

We are currently investigating this issue.
Posted Dec 16, 2025 - 14:30 CST
This incident affected: Brown County.