2205924 - Owen / Withee SD - Down

Incident Report for WiscNet

Resolved

The power outage has ended, the alarms have cleared.
Posted Feb 21, 2026 - 19:46 CST

Update

We are continuing to investigate this issue.
Posted Feb 21, 2026 - 19:46 CST

Update

We are seeing this site down. This site went down @ 5:12 pm. We have reports of power outages in the area, please confirm power on site and reach out if you have any questions.

Thanks,
Posted Feb 21, 2026 - 17:34 CST

Investigating

We are currently investigating this issue.
Posted Feb 21, 2026 - 17:30 CST
This incident affected: Owen-Withee School District.