[2289233] Saint Croix Falls - 2786 - Down

Incident Report for WiscNet

Update

Hello,

Our provider has informed us that this is due to a known maintenance event occurring in the area that will end at 7am.

We will provide updates when we receive the hands off for this maintenance.

Thank you,
Posted Sep 10, 2026 - 02:10 CDT

Investigating

Hello,

The WiscNet NOC has lost access to our device for Saint Croix Falls Area School District at 9/10 1:53am and are investigating. To assist with our investigation, please verify power to your site and the network equipment, then contact the WiscNet NOC at __noc@wiscnet.net__ or by phone at 608-442-6761.

Thank you,
Posted Sep 10, 2026 - 02:03 CDT
This incident affects: TEACH - Madison (Saint Croix Falls School District).