There was a major fiber cut along the path of the circuit carrying multiple members. The fiber cut was repaired and service was restored approximately 5 am
Posted Jun 26, 2025 - 07:49 CDT
Monitoring
Team,
The Wiscnet NOC is continues to work with our partner to isolate the cause of this event. No ETR is available at this time but further updates will be provided as they become available.
Thank you
Posted Jun 26, 2025 - 07:49 CDT
Update
We have engaged the provider, who acknowledged they are seeing a larger outage and will be engaging the local carrier.
Posted Jun 25, 2025 - 12:28 CDT
Investigating
We are seeing multiple member sites in northern Wisconsin have gone unreachable. We are engaging the provider for further investigation, and will provide updates once we have more information from them.
Posted Jun 25, 2025 - 12:00 CDT
This incident affected: Hurley School District, Mercer School District, North Lakeland School District, Northwood School District, and Solon Springs School District.