2270863 | Spectrum - Equipment Maintenance

Scheduled for Sep 25, 00:00 - 06:00 CDT

Update

Maintenance has been rescheduled to 09/25.
Posted Aug 06, 2026 - 07:37 CDT

Scheduled

Spectrum will be performing an equipment maintenance in multiple locations.

Anticipated Downtime: 120 minutes
Posted Aug 04, 2026 - 19:40 CDT
This scheduled maintenance affects: Baraboo School District, City of Beloit, and Monroe School District.