2231044 - Lutheran High School - Down

Incident Report for WiscNet

Postmortem

We suspect this was caused from multiple power outages in the area.

Posted Apr 27, 2026 - 21:42 CDT

Resolved

We are seeing this site restored and are also seeing multiple of the power issues in the area resolved as well.
Posted Apr 27, 2026 - 21:41 CDT

Investigating

Hello, We are seeing the connection to our onsite device offline as of approximately 15:06 CDT this afternoon, and we are reaching out for additional verification onsite.

We are wondering if you are aware of any power events onsite or if our equipment has any odd flashing lights. We are also recommending the internet devices onsite be rebooted in case of issues. If you need any additional assistance please feel free to reach out.
Posted Apr 27, 2026 - 15:37 CDT
This incident affected: Wisconsin Lutheran High School.