Medford Area Public School Disctrict Down | 2185079

Incident Report for WiscNet

Resolved

This incident is being resolved as a major incident has been opened on this issue
Posted Dec 17, 2025 - 08:10 CST

Investigating

At 3:57AM CST we observed the router at the Medford Area Public School District come into alarm indicating it is down. The device is not reachable at this time. Can you please verify power and equipment?
Posted Dec 17, 2025 - 04:43 CST
This incident affected: TEACH - Milwaukee (Medford Area Public School District).