#2248366 - Kenosha County Public Library System

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 9:54pm 6/11

Duration: 2 hours 51 minutes

Technician(s): Dylan, Payton

Review Date: 6/12/26

Brief Summary: WiscNet NOC lost access to the site router at 9:54pm on 6/11, and regained access at 12:45am on 6/12.

Root Cause: Loss of Power

Posted Jun 12, 2026 - 08:46 CDT

Resolved

Hello,

The WiscNet NOC regained access to the site router at 12:45am. Please reach out if you have any questions.
Posted Jun 12, 2026 - 08:44 CDT

Investigating

Hello,


We're seeing an issue with the router associated with Kenosha County Public Library System. If this is unexpected and if power is verified please reach out to 608-442-6761.
Posted Jun 11, 2026 - 22:40 CDT
This incident affected: Kenosha County Public Library System.