2288322 | Peshtigo School District (400585 & 400314) - Down

Incident Report for WiscNet

Resolved

We are observing Peshtigo School District restore at 7:49PM CDT 9/8/2026

Date & Time of Incident: 9/8/2026 6:16PM CDT - 7:49PM CDT

Duration: 93 minutes

Root Cause: Device at the Peshtigo School District lost power.
Posted Sep 08, 2026 - 20:16 CDT

Investigating

WiscNet has detected an outage for the Peshtigo School District at 6:16PM CDT. Please verify power to the equipment on-site.
Posted Sep 08, 2026 - 19:25 CDT
This incident affected: TEACH - Madison (Peshtigo School District).