[2281641] Crivitz School District - 400479 - Down

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 10:36 CDT

Identified

GLS/TEACH notified us of a network event at **Crivitz School District.** They are currently investigating this issue. Please verify power and equipment to your site. GLS/TEACH has opened ticket **12371861** for this incident. If you need further support, please contact the GLS/TEACH tech support.

If you have any further questions, please reach out to the WiscNet NOC.
Posted Aug 25, 2026 - 10:08 CDT