Wiscnet - Multiple Sites - Down | #2244123

Incident Report for WiscNet

Postmortem

All alarms cleared and services have been restored.

Posted Jun 04, 2026 - 04:18 CDT

Resolved

All services have restored and this incident will now be closed.
Posted Jun 04, 2026 - 04:17 CDT

Update

We have observed some services restore but some are still down. If you are still experiencing issues with your services, please reach out to 866-558-1920 once power has been verified. If there are any questions or concerns you can also reach out to 608-442-6751.
Posted Jun 04, 2026 - 03:57 CDT

Investigating

Hello,

At around 12:22AM CDT we started observing alerts indicating there is an outage on your service. Please reach out to 866-558-1920 once power has been verified. If there are any questions or concerns you can also reach out to 608-442-6751.
Posted Jun 04, 2026 - 01:36 CDT
This incident affected: TEACH - Madison (CESA 8, Gillett School District, Rock Prairie Montessori) and TEACH - Milwaukee (Milton School District).