Outage - Flambeau School District Down | 2223142

Incident Report for WiscNet

Update

GLS's carrier is wanting to dispatch to the site on Monday 4/13. According to GLS they've reached out to the local contact, the lcon is able to accommodate for that dispatch between 8 AM to 5 PM. GLS will reach out to us when they have a clear timeframe of an ETA on Monday. Please reach out to Wiscnet or GLS if you have any questions.
Posted Apr 12, 2026 - 06:15 CDT

Update

GLS has opened an investigation with their provider, they will provide further information to Wiscnet as they receive further updates on their provider's investigation.
Posted Apr 12, 2026 - 02:20 CDT

Investigating

We are currently seeing alarms indicating Flambeau School District is down. We have opened ticket 12065334 with GLS. We will update you again as soon as we receive new information.
Posted Apr 11, 2026 - 23:46 CDT
This incident affects: TEACH - Madison (Flambeau School District).