Outage - Winding Rivers Library Down | 2223142

Incident Report for WiscNet

Resolved

We have been informed this was due to a power issue on-site and alarms have cleared.
Posted Apr 09, 2026 - 10:09 CDT

Investigating

We are currently investigating this issue.
Posted Apr 09, 2026 - 07:36 CDT
This incident affected: TEACH - Madison (Winding Rivers Library System).