INC0263362 | WiscNet | Pewaukee School District | Issues reaching websites
Incident Report for WiscNet
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 13:39 CST
Investigating
Greetings,

Please be advised that we are currently investigating your reports of issues reaching websites. We will provide further information once available.

Please contact the WiscNet NOC if you have any further questions.

608-442-6761 option 1
noc@wiscnet.net
Posted Oct 23, 2023 - 11:45 CDT
This incident affected: Pewaukee School District.