Siren School District - Mass power outage | 2187084

Incident Report for WiscNet

Resolved

Hello,

At this time we are seeing all alarms cleared and services restored.

Please reach out with any questions.

Thank you,
Posted Dec 26, 2025 - 00:40 CST

Investigating

Hello,


It appears a mass power outage has taken down the location
Posted Dec 25, 2025 - 23:23 CST
This incident affected: TEACH - Madison (Siren School District).