Multiple sites down - 2237988

Incident Report for WiscNet

Postmortem

There were power outages in the area. The power has been restored to the area.

Posted May 17, 2026 - 23:10 CDT

Resolved

Hello,

We have seen alarms clear at all site. Please reach out to us if you have any questions.

Thanks,
Posted May 17, 2026 - 23:09 CDT

Update

We are continuing to investigate this issue.
Posted May 17, 2026 - 18:44 CDT

Investigating

At 3:50 we observed an outage at the following locations

Lakeshore Technical College
Mishicot School district
Two Rivers School District

We have observed that their is a power outage in the area. We will monitor for power restoral.
Posted May 17, 2026 - 18:43 CDT
This incident affected: TEACH - Milwaukee (Lakeshore Technical College, Mishicot School District) and TEACH - Madison (Two Rivers Public School District).