Packet loss reports for TEACH Members over WiscNet
Incident Report for WiscNet
Update
We have been advised that some changes have been made within the TEACH network and after checking with several members on this list we have seen speeds improve back to the level they were previously. If you are still seeing slow download speeds please let our Technical Support team know by emailing us at support@wiscnetl.net or calling us at 608-442-6761 option 2. If you need to reach us outside of our normal business hours, please contact our non at 608-442-6761 option 1 and ask to talk to the support specialist on call.
Posted Nov 07, 2024 - 13:42 CST
Update
We met today with all the operators of the network and there is a plan to do some testing this week to try and resolve the issue you are seeing. We will have updates as we progress.

Meanwhile, please let our Technical Support team know if you are experiencing issues by emailing us at support@wiscnetl.net or calling us at 608-442-6761 option 2. If you need to reach us outside of our normal business hours, please contact our non at 608-442-6761 option 1 and ask to talk to the support specialist on call.
Posted Nov 04, 2024 - 15:01 CST
Investigating
WiscNet has been receiving reports of slow download speeds ranging from 20-100Mbps from a small but growing subset of members with TEACH circuits. TEACH and WiscNet are troubleshooting the issue and will keep this Status Page updated as we learn more information about what is causing the issue.

Meanwhile, please let our Technical Support team know if you are experiencing issues by emailing us at support@wiscnetl.net or calling us at 608-442-6761 option 2. If you need to reach us outside of our normal business hours, please contact our non at 608-442-6761 option 1 and ask to talk to the support specialist on call.
Posted Nov 01, 2024 - 12:55 CDT
This incident affects: Bangor School District, Birchwood School District, Edgar School District, Grafton School District, Grantsburg School District, Hayward Community School District, Iola-Scandinavia School District, Lake Country School District, Medford Area Public School District, Siren School District, Spring Valley School District, and Woodruff J1 School District.